No audio in Soundmax

0

Just recently fixed a computer for someone that was doing my head in for a couple of hours.

The system was based on an m2npv-vm Asus motherboard with an onboard Soundmax High Definition audio chip. The problem? Windows xp was not detecting any sound devices, regardless how may times different revisions of the soundmax driver package was installed. I tried various fixes – all producing no sound. Again a massive Google search was undertaken with numerous results – A heap of users with the same issue.

Finally stumbled onto these two links: Softwaretipsandtricks which linked to an Annoyances.org post.

The fix: (quoted from above links and laid out for easy readability)

  • From Device Manager (be sure to select View/Show hidden devices), find the ‘ISAPNP Read Data Port’ device from the System Devices list. (Of note: once I successfully repaired this problem, this device no longer appears.)
  • Right click the ISAPNP device, and select “Update Driver”
  • Select “Install from a list or specific location”
  • Select “Don’t search. I will choose the driver to install.”
  • The step I left out on prior trials: UNSELECT “Show Compatible Hardware”
  • Be sure that “(Standard System Devices)” is selected under Manufacturer.
  • Under Model, scroll down until you see “Plug and Play Software Device Enumerator”. Select this item, and select “Next>”.
  • You will receive some frightening error message that you should probably disregard.
  • Complete the installation of the driver. You will see your device list magically change before your eyes. The other PNP devices will mysteriously become enabled and active. If not, restart.

I couldn’t find the original source to this fix but “Cheers Mate!” you saved me a reformat. The PC was recently loaded with an older version of the Nokia PC suite, this may of been the culprit in this case.

1 Comment
  1. Reply
    M Audio Blog » Blog Archive » No audio in Soundmax March 10, 2008 at 6:03 am

    […] jonny1989: The system was based on an m2npv-vm Asus motherboard with an onboard Soundmax High Definition audio chip. The problem? Windows xp was not detecting any sound devices, regardless how may times different revisions of the soundmax driver … […]

    Leave a reply

    Webmix Australia